Call Quality (Blue Network)

Incident Report for NUSO

Resolved

All calls are completing normally at this time.
Posted Sep 21, 2026 - 15:09 CDT

Update

We are continuing to monitor for any further issues.
Posted Sep 21, 2026 - 15:09 CDT

Monitoring

Some adjustments were made and we are monitoring at this time
Posted Sep 21, 2026 - 12:59 CDT

Investigating

We have had reports of intermittent call quality issue on the Blue Network. We have escalated this matter to our Engineering Department and they are actively working on it.
Posted Sep 21, 2026 - 11:11 CDT
This incident affected: CPaaS and Carrier/Network Services (Outbound Voice (Termination Services), Inbound Voice (Origination Services)) and Cloud Communications and Collaboration (UCaaS - Blue Platform).