Current Status: Fully Operational During CrowdStrike Outage
Incident Report for NUSO
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 17:02 CDT
Update
We are still monitoring the situation closely. So far, we have not received many calls that seem to be related to the CrowdStrike outage. Services appear to be working relatively well throughout the telecommunications industry. We will continue to monitor this situation for the rest of the day and provide updates as needed.
Posted Jul 19, 2024 - 11:36 CDT
Monitoring
Our services are currently operating normally with no issues. Everything is functioning as expected, and there are no disruptions to report.

However, we are aware that CrowdStrike has experienced major outages today, affecting various sectors including aviation, Microsoft-based systems, ISPs, and major telecommunications companies. This global issue might impact your ability to make calls, especially if you are using services from local carriers that are affected.

Key Points:

- Our services: Completely unaffected and operating smoothly.
- Potential external issues: Some users might experience difficulties due to their local carrier's involvement with the CrowdStrike outage.
- Recommendation: If you encounter any issues while making calls, please check with your local carrier for potential service disruptions.

This message is intended to keep you informed about the wider situation. Rest assured, our team is continuously monitoring our systems to ensure they remain stable and reliable.
Posted Jul 19, 2024 - 08:36 CDT