Telephone Number Management
Incident Report for NUSO
Resolved
The issue regarding new number ordering, porting, disconnects, and feature changes on Telephone Numbers has been resolved. Everything is now working as expected. Thank you for your patience and understanding. If you have any further concerns, please let us know.
Posted Feb 21, 2024 - 17:36 CST
Identified
We've identified the issue causing delays with new number ordering, porting, disconnects, and feature changes, and we're actively working to resolve it. There may still be temporary delays while we process a backlog of changes, but we'll keep you updated.
Posted Feb 21, 2024 - 11:27 CST
Investigating
We have received reports of concerns with new number ordering, porting, disconnects and feature changes on Telephone Numbers and want to assure you that it is being taken seriously. Our team has initiated an escalation process, ensuring that the appropriate resources are now actively engaged in addressing the issue.
Posted Feb 21, 2024 - 10:15 CST
This incident affected: NUSO.io Portal (Management Portal).