Calling Impacted on NUSO UCaaS Green Platform

Incident Report for NUSO

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 12:24 CST

Update

All services have been fully restored and are operating normally.
Posted Jan 16, 2026 - 12:23 CST

Update

Some issues remain, including impacts to EP1 and the Phone Builder. Our engineering team continues to work toward resolution. Calls are working with no issue. Call history and Call data ingestion is delayed but progressing.
Posted Jan 16, 2026 - 11:38 CST

Investigating

An issue has been identified affecting NUSO Green UC services. Our engineers are actively working to resolve the problem. We will provide updates as more information becomes available.
Posted Jan 16, 2026 - 10:22 CST
This incident affected: CPaaS and Carrier/Network Services (Outbound Voice (Termination Services), Inbound Voice (Origination Services)) and Cloud Communications and Collaboration (UCaaS - Green Platform).