Some Users Affected by Call Recording Access Issue
Incident Report for NUSO
Resolved
We have confirmed that the previously reported issue with accessing call recordings is now fully resolved. All services are operating as expected. We thank you for your patience and understanding during this time.
Posted Mar 14, 2024 - 13:24 CDT
Monitoring
The recent issue with accessing call recordings has been resolved. We are now actively monitoring the service to ensure everything is operating as expected.
Posted Mar 14, 2024 - 12:39 CDT
Update
Our investigation into the call recording access issue on the platform continues. We plan to restart the recording service overnight during a period of no usage. Further updates will follow as we progress.

Thank you for your patience.
Posted Mar 13, 2024 - 20:14 CDT
Update
Our team continues to investigate the root cause. At this time, no specific cause has been identified, and the issue still appears to be affecting a small subset of users.

We understand the importance of these recordings for your operations and are working to resolve this matter. If you need access to a specific recording(s), we encourage you to contact our support team for assistance.
Posted Mar 13, 2024 - 17:42 CDT
Investigating
We're currently investigating an issue on the Green/Netsapiens platform where call recordings might not be accessible, via the call history tab within the management portal, for some users. Not everyone is affected.

If you're experiencing difficulties and need access to a recording, please reach out to our support team for immediate assistance.
Posted Mar 13, 2024 - 13:20 CDT
This incident affected: NUSO.io Portal (Management Portal).