Inbound Email Issues for Support
Incident Report for NUSO
Resolved
Our support team worked with our email provider to identify and resolve the issue. Unfortunately, any emails that were rejected will need to be resent but moving forward all new emails will route as expected.
We apologize for any inconvenience caused during this period and appreciate your patience and understanding.
Posted May 24, 2023 - 15:06 CDT
Identified
We are currently experiencing problems with receiving inbound emails for support. As a result, we kindly request our valued customers to reach out to us directly by phone or utilize the management portal to open a ticket.
Our team is actively troubleshooting these email issues to resolve the situation as quickly as possible. We apologize for any inconvenience caused and appreciate your patience.
For immediate assistance, please contact our support team at (844) 438-6876 or submit a ticket through the Management Portal.
Posted May 24, 2023 - 13:10 CDT
This incident affected: Email (Inbound Support Email).