Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 06, 2026 - 00:00 CST
Scheduled
We will be performing a scheduled upgrade to the NUSO Green UCaaS platform during the early morning hours of January 6th as part of our ongoing efforts to improve platform performance, security, and reliability.
What to Expect:
- Modernized Call Recording service configuration and admin access pages
- Security updates
- Minor bug fixes
Impact on Services:
- Little to no downtime is expected during the maintenance window
Our team will closely monitor the upgrade to ensure a smooth transition with minimal impact.
If you experience any issues or have questions, please contact NUSO Support at support@nuso.cloud or (884) 438-6876.
Thank you for your continued support as we continue to enhance the platform.
Posted Dec 18, 2025 - 13:39 CST
This scheduled maintenance affected: Cloud Communications and Collaboration (UCaaS - Green Platform).