Customer administrative web portal connection issues
Incident Report for NUSO
Resolved
This incident has been resolved.
Posted Mar 24, 2023 - 20:37 CDT
Monitoring
We have identified and corrected this issue. All services Portal services are restored at this time. We will continue to monitor performance moving forward.
Posted Mar 24, 2023 - 18:58 CDT
Investigating
Some customers are experiencing issues connecting to the NUSO customer administration web portal. This may also prevent some users from logging into the mobile and desktop applications. All other systems are running as expected.

We are currently investigating the root cause of the issue and will update as we go. In the meantime, if you cannot connect to the web portal to make configuration changes, please contact our support team by phone or email:

(844) 438-6876
support@nuso.cloud
Posted Mar 24, 2023 - 18:34 CDT
This incident affected: NUSO.io Portal (Management Portal, User Portal) and Chat (Presence Status, Messaging, SMS).