Blue Network Calling Failure

Incident Report for NUSO

Resolved

NUSO Engineering has resolved the issue impacting the Blue Network. Inbound and outbound calling, including call quality, has returned to normal operation.

Our teams will continue to monitor the network to ensure service remains stable.

A formal Root Cause Analysis (RCA) / Reason for Outage (RFO) will be provided once the investigation and review are complete.
Posted Sep 18, 2026 - 16:21 CDT

Identified

Inbound and outbound calling on the Blue Network is currently operational.

We are continuing to observe intermittent call quality issues. NUSO Engineering is actively investigating and working to resolve the remaining service degradation.

We will provide additional updates as more information becomes available.
Posted Sep 18, 2026 - 14:52 CDT

Investigating

Our team has identified an issue within the Blue Network that is intermittently impacting the ability to place outbound calls.

Our Network Operations Center (NOC) has engaged NUSO Engineering, and teams are actively investigating the issue. We are currently awaiting additional findings and will provide an update as more information becomes available.

We apologize for any disruption and appreciate your patience while we work to restore normal service.
Posted Sep 18, 2026 - 12:06 CDT
This incident affected: CPaaS and Carrier/Network Services (Outbound Voice (Termination Services)) and Cloud Communications and Collaboration (UCaaS - Blue Platform).