St Louis Data Center impacted
Incident Report for NUSO
Resolved
All systems are now working correctly, and the issue is resolved.
Posted Jul 15, 2024 - 16:50 CDT
Update
We are seeing delays when accessing the Customer/Admin portals and this is causing intermittent connection issues when trying to access the portals. This will continue to improve over time and we will continue to monitor the situation closely to ensure stability.
Posted Jul 15, 2024 - 15:59 CDT
Monitoring
A power issue in the data center led to an equipment malfunction. The equipment was in a state where it was partially up, therefore things did not failover as expected. The hardware has been replaced and things appear to be working. We will continue to monitor the situation closely to ensure stability.
Posted Jul 15, 2024 - 14:38 CDT
Investigating
We are aware of and investigating a network-related issue that is causing some impact to Chat/SMS, Customer/Admin Portals, and some advanced Contact Center solutions. Our team is actively working to identify the cause and resolve the issue as quickly as possible.

We will provide more details as we learn more. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Jul 15, 2024 - 13:02 CDT