Intermittent issue with inbound emails
Incident Report for NUSO
Resolved
This incident has been resolved and all inbound emails are now routing as expected.
Posted Sep 01, 2022 - 16:06 CDT
Investigating
NUSO is investigating an intermittent issue with inbound emails into the support system. While NUSO is investigating the email system please call 844-438-6876 for any issues or questions and you will be connected to a live support representative.
Posted Sep 01, 2022 - 10:40 CDT
This incident affected: NUSO.io Portal (Management Portal).