Outgoing Email Delay
Incident Report for NUSO
Resolved
This issue has been resolved. All queued email messages have been delivered and there should be no delay moving forward.
Posted Apr 09, 2024 - 10:18 CDT
Investigating
We are investigating an issue with our outgoing mail service. At this time you may see a delay in email notifications from the Management Portal, E-Fax and number ordering.
Posted Apr 09, 2024 - 09:57 CDT
This incident affected: Email (Outbound Email Notifications) and Fax (Email Notifications).