Calling service is fully restored and operating normally. We appreciate your patience and understanding while our team worked to resolve the issue. A post-incident review is underway to help prevent a recurrence.
Posted Apr 20, 2026 - 18:06 CDT
Identified
We're seeing significant improvement in the intermittent call connectivity, and service is progressively being restored. Fewer than 1% of customers are still encountering intermittent issues as we work through the remaining impact.
Posted Apr 20, 2026 - 15:11 CDT
Investigating
We are aware of intermittent calling issues affecting some users. Calls may fail or take longer than usual to connect. Our team is actively investigating, and we'll share an update as soon as we have more information.
Posted Apr 20, 2026 - 11:56 CDT
This incident affected: Cloud Communications and Collaboration (UCaaS - Orange Platform, UCaaS - Green Platform, UCaaS - Blue Platform, NUSO Connect for Business, NUSO Bridge for Teams, NUSO Bridge for Zoom, SimplyConnect/MessageView, Microsoft Operator Connect) and CPaaS and Carrier/Network Services (Outbound Voice (Termination Services), Inbound Voice (Origination Services)).