eFax Service Impairment

Incident Report for NUSO

Resolved

efax service has been restored and all systems are operating normally.
Posted Mar 03, 2026 - 10:52 CST

Investigating

NUSO is currently experiencing intermittent failures with inbound and outbound calls specific to the eFax service. Our Engineering team is actively investigating the issue. Traditional voice services on the Blue platform remain unaffected.
Posted Mar 03, 2026 - 09:48 CST
This incident affected: Cloud Communications and Collaboration (UCaaS - Blue Platform).