Blue Calling/Fax Issues

Incident Report for NUSO

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 16:05 CDT

Update

We are continuing to monitor for any further issues.
Posted Sep 17, 2026 - 16:05 CDT

Monitoring

We have identified the underlying issue affecting the Blue platform and applied a fix at 1:13 PM Central Time. We will continue to monitor performance to ensure service remains stable.
Posted Sep 17, 2026 - 13:37 CDT

Investigating

We are aware of reports of intermittent call and fax issues on the Blue platform and are actively investigating. We will provide updates as more information becomes available.
Posted Sep 17, 2026 - 12:10 CDT
This incident affected: Cloud Communications and Collaboration (UCaaS - Blue Platform).