Toll Free calling Impacted
Incident Report for NUSO
Resolved
This incident has been resolved, the issue was related to Toll Free calls going to or from the Verizon network. Verizon made changes last night and Toll Free services continue to function as expected.
Posted Oct 07, 2021 - 07:41 CDT
Update
Toll Free calls are now being delivered as expected. We will continue to monitor the situation and will update if there are any new changes, but as of now Toll Free services are fully functional.
Posted Oct 06, 2021 - 22:36 CDT
Monitoring
A small subset of Inbound toll free calls may not complete as expected. Downdetector.com is identifying major carriers now having trouble delivering Toll Free calls. This Toll Free impairment is outside of the NUSO network and does not affect every call.

We continue to monitor the situation and will update we have more information.
Posted Oct 06, 2021 - 22:07 CDT
This incident affected: Voice - Inbound (UCaaS, SIP, Contact Center).