Monitoring Network Issue
Incident Report for NUSO
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 10:46 CDT
Update
The NUSO network remains stable and continues to operate as expected.
Posted Oct 04, 2021 - 12:04 CDT
Update
The issue with DTMF has been identified and we believe it is resolved. At this time all NUSO services remain stable however we will continue to monitor the status of the network and its components.
Posted Oct 01, 2021 - 10:51 CDT
Update
Call operations remain stable. However, we are experiencing intermittent DTMF issues with a small fragment of the network where we moved numbers off of the impacted carrier yesterday. We expect to have it resolved soon. All parties are aware of the issue and it has been escalated. We will update you when we have additional information.
Posted Sep 30, 2021 - 16:10 CDT
Update
All NUSO Services are currently operational. NUSO will continue to monitor the network partner that has been impacted over the past week. The vast majority of customer telephone numbers no longer route through the affected partner. We are continuing to move the remaining telephone numbers to other network partners and will effort to move them all as soon as possible. We will continue to update as conditions warrant.
Posted Sep 30, 2021 - 06:27 CDT
Update
NUSO operations has completed phase one of transitioning telephone numbers to working networks. This is well over 90 percent of the numbers that were affected.

Phase two continues on the remaining numbers that are more difficult to move. They will continue to be completed in small batches every 2 to 4 hours until complete.

We will begin communicating with partners as to which of their customers have been moved starting in the morning.

We will continue to update until this issues is resolved
Posted Sep 29, 2021 - 19:35 CDT
Update
The underlying service provider has confirmed that they are once again under an attack and are experiencing issues with inbound and outbound calling. We have been transitioning telephone numbers throughout the day and by the end of the day we anticipate 90% of impacted customers will be moved to an entirely separate network which is not impaired.

Please note: Most of our customers may not notice or be directly impacted by the disruption as of this morning. The service provider who is under attack is one of the top three service providers by volume in the nation. Therefore, their problems are impacting many other service providers. You may be calling, or receiving, from or to a provider who is also using the underlying carrier.
Posted Sep 29, 2021 - 13:43 CDT
Update
We are getting reports that the partner network is again failing which seems to indicate they are under attack this morning. We have no update from that service provider. NUSO is continuing to move numbers to an entirely separate network that we have verified is not a part of the attack. We will be working through this today. It will take time to transition numbers. We will regularly update.

As of this morning we have transitioned all Toll-Free services as well as a vast majority of local telephone numbers. We expect to have most numbers transitioned by COB today. Numbers will be transitioning in batches through the morning/afternoon.

If your number has already transitioned, there is still a chance that if you are trying to call someone, or be called by someone, there may still be issues. The service provider who is under attack is a nationwide service provider and is impacting many other carriers/providers. Your customers may be calling from/to a provider who is also using the underlying carrier.
Posted Sep 29, 2021 - 08:33 CDT
Update
The NUSO network remains 100% functional with no currently known issues. As of this morning all of the impacted upstream carrier partner appears to be functional. NUSO is still moving forward with moving the remainder of the telephone numbers still on the impacted carrier. We expect batches of numbers to continue to transfer each hour. We will update you throughout the morning.
Posted Sep 29, 2021 - 07:24 CDT
Update
We have converted all Toll Free services that were on the impacted network and moved the vast majority of the local telephone numbers that were attached to that network. The impacted network is still having trouble as of this hour. The trouble is having a much smaller impact on the overall NUSO network as we have reduced the profile of the network as part of the NUSO ecosystem.

For those still being impacted, we are working as fast as we can to move your service off of the affected network. We will continue to update you as conditions warrant.
Posted Sep 28, 2021 - 21:16 CDT
Update
The remaining Toll Free services on the impacted carrier are currently being moved and should be complete within the hour. We have loaded an additional 64,000 numbers that are in queue to move yet this afternoon.
Posted Sep 28, 2021 - 15:13 CDT
Update
The first batch of numbers has moved from the impacted carrier and they are working as expected. We will continue transferring numbers until the job is complete.
Posted Sep 28, 2021 - 13:55 CDT
Update
We are expecting to have the first 3,000 numbers moved in this hour, then we will begin moving tens of thousands of number per hour the remainder of the afternoon for the remaining impacted customers.
Posted Sep 28, 2021 - 12:04 CDT
Update
We have begun the phase of moving the impacted numbers. It does require some time as the impacted carrier is taking extra time to release the numbers. We will update the counts of customers and numbers achieved throughout the day.
Posted Sep 28, 2021 - 10:29 CDT
Update
We continue to see degraded inbound calling to a subset of our customers. This is due to the calls never reaching the NUSO network. The NUSO network itself is operational. We will continue to update as we work to re-route the impacted numbers.
Posted Sep 28, 2021 - 09:05 CDT
Update
We are getting reports that the partner network is again failing which seems to indicate they are again under attack. We have no update from that service provider. NUSO is taking the step of beginning to move our numbers to an entirely separate network that we have verified is not a part of the attack. We will be working through this today. It will take time to transition numbers. We will regularly update.

Customers that are not on the impacted network will not experience any change in service and will continue working as planned.
Posted Sep 28, 2021 - 08:58 CDT
Update
We have confirmed that the national telephone network outages that occurred in the past few days culminating with the long degradation of service yesterday was a coordinated attack on one of our network partners. Public news reports and status pages of many large national networks indicate they were impacted as well.

The NUSO network itself is 100% functional, it is the delivery of calls through one of our four primary network partners that has been disrupted. We are also implementing additional precautions as our engineers make determinations on changes to the network.

NUSO already rerouted the majority of affected traffic on Saturday when the attack began. We are preparing to move the remainder if the attack persists or restarts.
Posted Sep 28, 2021 - 08:18 CDT
Update
The upstream carrier has reported that all services are operational and our testing reflects that. We will continue to monitor but at this time all services are restored.
Posted Sep 27, 2021 - 19:22 CDT
Update
As of 6:28 PM Central time the upstream carrier has reported that they are now observing expected network behavior. Preliminary tests show that inbound service is restored. We will continue to monitor the situation closely.
Posted Sep 27, 2021 - 18:44 CDT
Update
Today has been difficult for many of our customers to send and receive calls and complete their normal business. We are sorry for any negative consequences that may have taken place.

Let me inform you as to what is occurring and what we might expect in the coming days.

Over the past few days and beginning in earnest on Saturday, one of the largest networks that sends and receives IP voice traffic in the United States was hit with an attack. Many networks are hit with attacks everyday where there is no impact to the network. In this case, even though they are making every effort, the network is being impacted. Due to the size of this network, virtually all service providers are affected in one way or another.

This main service provider is not the only one being attacked in the past few days. Public reports put two domestic US carriers and up to three European providers that have been attacked with a negative result on service quality.

If you need to reach our Network Operations Center we have established new and additional telephone numbers routing around the trouble:

855-458-2220
314-690-0660

You can also check our status at https://status.nuso.cloud

For the good news – all of NUSO’s infrastructure is 100% functional and is not compromised. We have now limited any impact to customers that have telephone numbers that are traversing the carrier under attack. Customers that have telephone numbers on other carriers will not be directly impacted.

That does not mean that all calls will go through. This outage is large enough that many customers will continue to experience problems since a large portion of other service providers networks also use this carrier, and their calls will simply never reach the intended or fail after reaching the NUSO network.

We are working to determine if it is possible to route completely around the degraded network as quickly as possible. We will update you as to our progress regularly through the day tomorrow.

Thank you for being a NUSO customer and we will keep working to make sure your services are functional and resilient.

Matt Siemens, CEO
Posted Sep 27, 2021 - 17:18 CDT
Update
As of 4:00 PM central time on 9/27/2021 we have no update on resolution from the upstream carrier as to when the issue will be resolved. We continue to monitor the situation and will update when we have more information.
Posted Sep 27, 2021 - 16:10 CDT
Update
As of 2:00 PM central time on 9/27/2021 Incoming calls remain impacted for a portion of our customers. It appears that the negatively impacted calling patterns are regional in nature. The outages are now multiple in nature external to the NUSO network. Downdetector.com is identifying 7 major carriers now having trouble delivering calls on their front page. We are finding many calls have no trouble on either our network or the network delivering calls to NUSO but the originating call is passing through the impacted network at some point and therefore failing or having one-way audio. Even when we re-route traffic on our side, the call quality will not improve because the calls are outside the NUSO controlled network. NUSO continues to work through this 3rd party outage to address customer traffic. We will continue to update you as conditions change.
Posted Sep 27, 2021 - 14:09 CDT
Update
As of 1:40 PM central time on 9/27/2021 we have no update on resolution from the upstream carrier as to when the issue will be resolved. We continue to monitor the situation and will update we have more information.
Posted Sep 27, 2021 - 13:45 CDT
Update
As of 11:50 AM central time on 9/27/2021 we have no update on resolution from the upstream carrier as to when the issue will be resolved. We continue to monitor the situation and will update we have more information.
Posted Sep 27, 2021 - 12:00 CDT
Monitoring
Starting at 10am central time on 9/27/2021 one of NUSOs underlying carriers again began experiencing significant technical difficulties with their inbound service. This is not a full outage. This underlying carrier is used by roughly 80% of other service providers to some degree in the US.

NUSO’s network is not impacted but calls that flow through the external carrier are being impacted. A significant portion of NUSO’s customers will not experience any problem at all as their call flows will not route through the impacted network.

We are monitoring the situation and watching it carefully. We will continue to update you.

Please use the following phone numbers to reach our network operations center (NOC) during this event in order.

855-458-2220 or 314-690-0660
Posted Sep 27, 2021 - 10:00 CDT
This incident affected: Voice - Inbound (UCaaS, SIP, Contact Center).